Hammer Linux Board

Recently I’ve been doing some work with a TinCan Tools Hammer embedded Linux board. The hammer board is a neat little piece of hardware in a 40-pin DIP form factor, it looks good from a hardware point of view although unfortunately lacking a bit in the documentation area. I had some recent frustration getting MMC/SD card support to work which turned out to be a problem in the driver, their Linux programmer tracked it down and supplied the new mach-tct_hammer.c file required to fix things from a driver point of view.

Then I had some frustration because using buildroot as per the supplied configuration was giving me different results to the filesystem loaded onto the device at the factory, namely that it ended up being mounted read only. An attempt to remount the root partition read/write complained that /proc/mounts was missing which I was able to solve by adding the following lines to the device_table.txt file:

/proc        d    777    0     0    –    –    –    –    –
/proc/mounts    d    777    0     0    –    –    –    –    –
/proc/devices    d    777    0     0    –    –    –    –    –

Once these lines were included the root filesystem was mounted read/write by default. I then went on to add the following to device_table.txt:

/dev/mmcblk0     b     777     0    0     179     0     –     –     –
/dev/mmcblk0p1     b     777     0    0     179     1     –     –     –
/mnt/mmc    d    777    0    0    –    –    –    –    –

After which I was able to successfully mount a 4GB FAT32 formatted SD card using the command:

mount /dev/mmcblk0p1 /mnt/mmc

4 thoughts on “Hammer Linux Board”

  1. Dear Peter Johnson,

    I am having the same problem using buildroot for hammer board. I made changes into the devices_table.txt but I still get a read-only root filesystem.
    Would you help me to fix it?


    Paulin Bekambo

  2. Hi Paulin, a customer has the hammer board at the moment using it in their application gathering data from a Bluetooth accelerometer and GPS, however I would be happy to try my best. Which version of the kernel are you trying to use? The version I had success with is 2.6.29 that I built myself because I need changes to get the SD card working, although I’d guess the filesystems have changed much between kernel versions so it shouldn’t really matter.

    One thing I noticed though is that the default filesystem that came on the device would mount read/write OK, I restored the image supplied on the CDROM and it worked OK but the default buildroot supplied on the CD didn’t give the same result. I guess a good first step might be to restore that default file system for a start to make sure it mounts as read/write OK with the kernel you’re using. If that works maybe I could place the buildroot I was using at a location on the web so you can download and try exactly what I was using.

Leave a Reply

Your email address will not be published. Required fields are marked *